Delayed Apple Healthkit uploads with the StrivePD app

Incident Report for Rune Labs Status Page

Resolved

A fix for the delayed Apple Healthkit upload is now available. Please visit the Apple AppStore and update your StrivePD app to version 2.12.1. You will then be prompted to accept new permissions when you open the StrivePD app. Users that have auto app update enabled should automatically get the update over the next 12 hours. Thank you again for your patience. Please contact our support team if you have taken the above steps and continue to experience issues. (support@runelabs.io)
Posted Feb 25, 2025 - 19:39 UTC

Monitoring

A fix for the delayed Apple Healthkit upload is now available. Please visit the Apple AppStore and update your StrivePD app to version 2.12.1. You will then be prompted to accept new permissions when you open the StrivePD app. Users that have auto app update enabled should automatically get the update over the next 12 hours. We will continue to monitor to verify that we see resumed Apple Healthkit syncing from affected users. Thank you again for your patience. Please contact our support team if you have taken the above steps and continue to experience issues. (support@runelabs.io)
Posted Feb 20, 2025 - 17:55 UTC

Update

We are continuing to work on a fix for this issue. A fix has been built and tested and is moving to be submitted to Apple for review. Thank you for your patience, and please continue to check back anytime to this status page for updates or steps to take to ensure the best StrivePD experience.
Posted Feb 19, 2025 - 23:02 UTC

Update

HealthKit sync is paused for some users of StrivePD version 2.12.0. Expected resolution is tomorrow when StrivePD version 2.12.1 is available in AppStore.
Posted Feb 19, 2025 - 22:50 UTC

Identified

We are currently investigating an issue where users are experiencing delayed Apple Healthkit uploads with the StrivePD app. We have identified the issue and are in the process of resolving. Thank you for your patience while we look into the issue, and please continue to check back anytime to this status page for updates or steps to take to ensure the best StrivePD experience.
Posted Feb 19, 2025 - 22:41 UTC
This incident affected: StrivePD iOS Application.